При обновлении проекта на yii2 через composer стало возникать предупреждение:

$ composer update
Deprecation Notice: Composer\Package\Version\VersionParser::parseLinks is deprecated. Use \Composer\Package\Loader\ArrayLoader::parseLinks() instead in phar://C:/ProgramData/Composer/bin/composer.phar/src/Composer/Package/Version/VersionParser.php:226
...

Обновил сам composer через self-update, всё стало хуже:

$ composer update 
PHP Fatal error:  Call to undefined method Fxp\Composer\AssetPlugin\Package\Version\VersionParser::parseLinks() in /root/.composer/vendor/fxp/composer-asset-plugin/Repository/VcsPackageFilter.php on line 272 

Но стало ясно что проблема в плагине "composer-asset-plugin". Решил так:

1. Откатил обновление composer:

$ composer self-update --rollback

2. Обновил плагин:

$ composer global require "fxp/composer-asset-plugin:~1.0.3"

3. Обновил composer:

$ composer self-update

Всё заработало как надо.